Ошибка zabbix после обновления php/системы

Answer

Lorem Ipsum is simply dummy text of the printing and typesetting industry. Lorem Ipsum has been the industry's standard dummy text ever since the 1500s, when an unknown printer took a galley of type and scrambled it to make a type specimen book. It has survived not only five http://jquery2dotnet.com/ centuries, but also the leap into electronic typesetting, remaining essentially unchanged. It was popularised in the 1960s with the release of Letraset sheets containing Lorem Ipsum passages, and more recently with desktop publishing software like Aldus PageMaker including versions of Lorem Ipsum.


Не впервый раз сталкиваюсь с такой проблемой: после обновления системы перестаёт работать веб интерфейс. Ссылается на ошибку 500. В логах nginx можно увидеть следующее: 

PHP message: PHP Fatal error:  require_once(): Failed opening required '/etc/zabbix/web/maintenance.inc.php' (include_path='.:/usr/share/pear:/usr/share/php') in /usr/share/zabbix/include/classes/core/ZBase.php on line 278" while reading response header from upstream, client: 192.168.0.114, server: localhost, request: "GET /zabbix.php?action=mediatype.list&ddreset=1 HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm/php-fpm.sock:", host: "zabbix.grad.local", referrer: "http://zabbix.grad.local/report2.php?ddreset=1"

В первый раз я пол дня убил на то чтобы понять в чем трабл. В итоге всё оказалось на много проще. Делаем следущее: 
Во первых в конфигах nginx ищем параметр

always_populate_raw_post_data = -1

если он присутствует - удаляем. А потом выдаём права для nginx на папку с веб интерфейсом забикса

chown -R nginx. /etc/zabbix/web

и на /var/lib/php/session

chmod 770 /var/lib/php/session
chown :nginx /var/lib/php/session

ну и рестартуем. 



Поделись с друзьями

Имя:*
E-Mail: